Delayed Spire Weather and Climate Products

Incident Report for Spire Weather

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 19:37 UTC

Identified

One of our high performance compute vendors is having operational issues after yesterdays maintenance downtime. We are working with them to resolve the issue.
Posted Aug 20, 2025 - 12:41 UTC
This incident affected: Spire Weather Forecast - Global Atmospheric Data, Spire Weather Forecast - Global Maritime Data, Spire Weather Forecast - Custom Global Data, and Spire Weather Current Conditions - Global Data.