Delayed Spire Weather and Climate Products

Incident Report for Spire Weather

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 21:41 UTC

Identified

We have identified an issue with our service provider which is causing partial disruption in services. We are actively working to resolve the issue as soon as possible and will keep you posted on the status.
Posted Oct 20, 2025 - 16:21 UTC
This incident affected: Spire Weather Forecast - Global Atmospheric Data, Spire Weather Forecast - Global Maritime Data, Spire Weather Forecast - Custom Point Data, Spire Weather Forecast - Custom Global Data, Spire Weather Current Conditions - Global Data, Spire Weather WMS, Spire Weather API, Spire Weather Historical Data Service, Spire Weather Forecast - High-Resolution Forecast - CONUS, Spire Weather Forecast - High-Resolution Forecast - Europe, and Spire Weather Forecast - High-Resolution Forecast - Equatorial-Southeast-Asia.